aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorevuez <julien@mulga.net>2024-04-03 22:43:16 +0200
committerevuez <julien@mulga.net>2024-04-03 22:43:16 +0200
commit43e1a12b5bce11b4a28a53acca243e35c2be6d3e (patch)
tree07d64823718bfee063ab7b3d5721ac1e950ae17c /Cargo.toml
downloadcarton-43e1a12b5bce11b4a28a53acca243e35c2be6d3e.tar.gz
Initial commit
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..c19889d
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,22 @@
+[package]
+name = "carton"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+blake3 = "1.5.0"
+data-encoding = "2.4.0"
+data-encoding-macro = "0.1.13"
+env_logger = "0.10.0"
+fastcdc = "3.1.0"
+fuser = "0.13.0"
+libc = "0.2.149"
+log = "0.4.20"
+rand = "0.8.5"
+rusqlite = { version = "0.29.0", features = ["time"] }
+serde = { version = "1.0.188", features = ["derive"] }
+serde_json = "1.0.107"
+time = { version = "0.3.29", features = ["serde"] }
+toml = "0.8.8"